#configuração

Configurando modem 3g Tim Onda MSA110up no Ubuntu 10.10


Ei pessoal!!!

Acabo de consegui conectar pela primeira vez, meu modem 3g da Tim após um mês tentando configurar no Linux (Fedora/OpenSuse/Ubuntu).

Então essa luta merece um post para ajudar os leitores a passarem menos raiva do que eu.

Segue o passo-a-passo da instalação no Ubuntu 10.10 Maverick:

1º Baixe e instale os .deb (E não se esqueça de baixar as dependências):

usb-modeswicth

usb-modeswitch-data

wvdial

2º Edite o arquivo /etc/usb_modeswitch.d/19d2\:2000

Na linha:


TargetProductList=
"0001,0002,0015,0016,0017,0031,0037,
0052,0055,0063,0064,0108,0128"

Acrescente o código 0091que é o código do produto do modem MSA110up:


TargetProductList=
"0001,0002,0015,0016,0017,0031,0037,
0052,0055,0063,0064,0108,0128,0091"

3º Edite o arquivo /etc/wvdial.conf (Verifique em qual /dev/ttyUSB o seu modem foi detectado, no meu caso foi em /dev/ttyUSB3)

[Dialer tim]
 Init2 = ATZ
 Init3 = AT+CGDCONT=1,"ip","tim.br"
 Stupid Mode = 1
 ISDN = 0
 Phone = *99***1#
 Ask Password = 0
 Modem = /dev/ttyUSB3
 Username = tim
 Dial Command = ATDT
 Password = tim
 Baud = 460800

4º Execute os comandos:

# Para reconhecer como modem USB e não como storage
usb_modeswitch -c /etc/usb_modeswitch.d/19d2\:2000

# Para iniciar a conexão
wvdial tim

5º Enjoy \o/

Estes passos são uma compilação de vários post, dentre eles:

Tim-Web no Linux – Onda MSA501HS

Modem 3G tim-web Onda MSA523HS e similares

Ubuntu Fórum

[Editado]

As configurações acima também funcionam para o Fedora 14, baixando os pacotes RPM citados e glibc.

As configurações no Fedora 14 comportaram de forma instável.

Recomendo a instalação do Gnome-PPP para realizar a conexão usando as informações do arquivo /etc/wvdial.conf

Deixe em branco o campo Dial prefix e desmarque a opção Check carrier line.

Eu precisei executar o Gnome-PPP como root pois ele precisar de permissão para executar operações internas.

Possíveis erros:

– Invalid Dial Command

Desconecte o modem, reconecte e aguarde o usb_modeswicth realizar a alteração para speed drive, depois execute novamente a chamada ao wvdial.

Para visualizar a conversão execute:


tail -f /var/log/messages

[/Editado]

Até breve.

Anúncios
Padrão

75 comentários sobre “Configurando modem 3g Tim Onda MSA110up no Ubuntu 10.10

  1. Alexandre Magno disse:

    Olha, admirável o esforço de vcs, mas me pergunto, um trabalhão desses so pra instalar um modenzinho, porque não tornar isso mais facil como o windows, que basta conectar o modem e clicar em avançar, avançar e pronto, já se pode usar em 5 min. Estou com um notebook de um amigo com linux pra instalar esse modem, mas já desisti, e a linguagem não ajuda, pra quem não conhece nada de Linux, isso é uma complicação.

    • Marcelo E. Geyer disse:

      Eu tenho este modem mas não tenho mais plano 3G. Fiz um teste aqui com o último kubuntu (12.04) e ele reconhece o modem sem nenhuma intervenção. Resta saber se vai conectar corretamente.

  2. André disse:

    Tenho um modem onda msa 110UP , ele pediu pra instalar uma versao nova, sendo que informou que eu deveria desinstalar a versao 2.4.0.0 , eu desinstalei normal, sumiu tudo dele, so que quando eu coloco meu modem, ele continua dizendo que a outr versao ainda esta instalada… oq faço?

  3. sergio disse:

    Porque no linux é tudo tão complicado,porque as informações estão sempre “retalahdas”.Toda distribuição linux deveria vir sempre com um manual completo ou um mini curso imbutido de como usa-la.

    • Marcelo E. Geyer disse:

      Sérgio, as dificuldades com esses pen modens ocorre porque o fabricante não oferece suporte para o sistema operacional e geralmente quem provê as funcionalidades são os usuários/comunidade. Se você pegar um modem Huawei por exemplo, não precisa fazer nada, o sistema reconhece e basta configurar o networkmanager para conectar, não precisando recorrer ao wvdial neste caso (ou seja, este tutorial)

    • Marcelo E. Geyer disse:

      Aproveitando, você pode COMPRAR uma distribuição Linux, por exemplo o Mandriva, tem edições que vem um box com manual, mas não espere achar no manual soluções para todos os problemas, nem a Microsoft oferece isso nos manuais dela (não me fale em base de conhecimento do site pois isso não vale, se for assim verifique então os wikis e foruns das distribuições na internet, sem falar que há manuais on-line também, é o caso do Fedora)

  4. jorge disse:

    ( conexao de internet via bluetooth )
    use a internet do seu celular no seu pc ou notebook (importante lembrar q o pc ou notebook tenha essa conexao e que o celular tenha pacote de internet contratada)
    1# passo – ligue ambos dispositivos
    2# clique no menu iniciar / dispositivos e impressoras / adicionar um dipositivo/ (sera instalado)
    3#clique em /conectar a internet
    4# conectado ou nao aprecera uma caixa de dialogo clique em cancelar ( estas sao conf. avançadas sao recomendadas ) nesta caixa va em /propriedades /geral va em conf. altere a veloc. ative as opcoes menos a ultima em regas de discagem ative (coloque discagem de pulso) e insira codigo de area e ddd se tiver em sp coloque 11 e ddd 21 em conf. ppp ative tudo em /seguarança ative todos os protocolos em /rede ative todos altere as opçoes de dicagem e redisgem a seu modo ( imporante nao mudar o numero de dicasgem a menos que conheça outro que funcione ou inclua). parece complicado mais e um processo simples esta opcao aparecera no seu assistente de conexoes ( bluetoothconection) .
    (è importante verificar se o moldem bluethooth esta selecionado em /propriedades, sempre que se conectar e certifique se q ambos o bluetooth esteja sempre ligado). ja foi..

  5. jorge disse:

    Este moldem da tim e desbloqueado nao tem segredo, se vc tivesse usado o codigo *91***1# para discar seu sofrimento teria acabado desde de o começo. outra dica vc pode tambem personalizar o moldem usando as mesmas configuraçoes grs do celular e tambem a conexao discada com o mesmo codigo. entrando em propiedades vc pode alterar desde o acesso ate a velocidade. ( outra detalhe importante gerando conexoes gprs nao significa q vc possa acessalas ou q possa trocar de rede pois tera que ter o plano contratado essas conexoes so vao contribuir comtribuir com a sua velocidade na internet e como se fosse aceleradores de internet. bom espero telos ajudados.

      • Eu também não descobrir. O que posso dizer é que com o comando dmesg vocês conseguem visualizar os possíveis /dev/ttyUSB. Geralmente varia entre 0 e 4, tente os que aparecerem na listagem gerada pelo dmesg. Depois de encontrar o o ttyUSB utilizado, dificilmente será preciso alterá-lo.
        Espero ter ajudado.

  6. Geraldo Barbosa Landre disse:

    Geraldo Barbosa Landre :

    Oi Brena! Como vai? Andei muito ocupado com outras coisas e agora que tive um tempo pra tentar resolver este problema de novo…
    Veja abaixo a saída do comando lspci, não consegui identificar o número…
    geraldo@queen:~$ lspci
    00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
    00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
    00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
    00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
    00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
    00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
    00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
    00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
    00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
    05:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01)
    06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
    ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
    ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
    ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
    ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
    ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
    ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
    Obrigado!
    Geraldo

    Ahh complementando… fiz um lsusb aqui e a saída e essa que segue abaixo, o número do meu seria 018 então??

    root@queen:/home/geraldo# lsusb
    Bus 002 Device 018: ID 19d2:0091 ONDA Communication S.p.A.
    Bus 002 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
    Bus 002 Device 003: ID 5986:0190 Acer, Inc
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 004: ID 0489:e00d Foxconn / Hon Hai
    Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

      • Geraldo Barbosa Landre disse:

        Brena, e quanto a este erro? ele ainda continua:
        $ sudo wvdial tim
        saída:
        –> WvDial: Internet dialer version 1.60
        –> Cannot open /dev/sg4: Invalid argument
        –> Cannot open /dev/sg4: Invalid argument
        –> Cannot open /dev/sg4: Invalid argument

        Não sei qual device devo utilizar…

        Como eu vou descobrir?

        • Geraldo
          Você deve alterar o device, para algo parecido com /dev/ttyUSB0 o que você informou não é referente ao USB.
          Para descobrir você pode conectar o modem, esperar a conversão e executar o comando:
          $ sudo wvdial
          Que irá tentar configurar automaticamente seu modem. Após essa configuração verifique no arquivo /etc/wvdial.conf, qual valor ele setou para a propriedade Modem.
          Se ele tiver setado algum valor substitua pelo device que você informou (/dev/sg4). E deixe no arquivo /etc/wvdial.conf somente a configuração [Dialer tim] criada anteriormente.
          Uma outro tentativa seria instalar o gnome-ppp e tentar conectar por ele passando campo a campo os parâmetros utilizados no /etc/wvdial.conf
          Espero ter ajudado, fico no aguardo.
          Até breve 😉

  7. Geraldo Barbosa Landre disse:

    Olá Brena, tudo bem?

    Estou aqui tentando configurar meu modem ONDA MSA190UP, no Ubuntu 10.10.
    Segui o passo-a-passo que você sugeriu, baixei os pacotes e depois de alguns conflitos de dependências, consegui instalar o wvdial e o usb_modeswitch.
    Adicionei o 0091 no arquivo /etc/usb_modeswitch.d/19d2\:2000 conforme orientado.
    Mas nos passos seguintes ainda não obtive sucesso, algumas dúvidas que seguem:

    1o. Device:
    Não consigo determinar em qual device meu modem foi conectado, vc tinha sugerido /dev/ttyUSB*, mas no meu caso, não tem nenhum deste tipo…
    O comando: $ ls /dev/tty*
    resulta em tty de 0 até 61…

    O comando: $ dmesg | grep ONDA
    resulta em:
    [22323.186031] scsi 8:0:0:0: Direct-Access ONDA MMC Storage 2.31 PQ: 0 ANSI: 2
    [22484.914339] scsi 10:0:0:0: Direct-Access ONDA MMC Storage 2.31 PQ: 0 ANSI: 2
    [23416.697040] scsi 12:0:0:0: Direct-Access ONDA MMC Storage 2.31 PQ: 0 ANSI: 2
    [23859.978295] scsi 14:0:0:0: Direct-Access ONDA MMC Storage 2.31 PQ: 0 ANSI: 2
    [25357.423373] scsi 16:0:0:0: Direct-Access ONDA MMC Storage 2.31 PQ: 0 ANSI: 2
    … Essa saída não me ajudou em nada, bola pra frente:

    Analisando o log, como vc sugeriu, percebi as seguintes linhas:
    May 16 23:12:04 queen kernel: [26936.296245] usb 2-1.1: new high speed USB device using ehci_hcd and address 16
    May 16 23:12:04 queen usb_modeswitch: switching 19d2:2000 (ONDA,Incorporated: ONDA WCDMA Technologies MSM)
    May 16 22:45:42 queen kernel: [25357.424715] sd 16:0:0:0: Attached scsi generic sg4 type 0
    May 16 22:45:42 queen kernel: [25357.429223] sd 16:0:0:0: [sdd] Attached SCSI removable disk
    … O usb_modeswitch está trocando correto? Ele primeiro fala “… high speed …” e depois fala que está trocando… é isso mesmo?
    … Observando as linhas que seguem, eu pesquisei e percebi que existem os devices: /dev/sdd e /dev/sg4, tentei configurar com as duas opções, sem sucesso:

    $ sudo wvdial tim
    saída:
    –> WvDial: Internet dialer version 1.60
    –> Cannot open /dev/sg4: Invalid argument
    –> Cannot open /dev/sg4: Invalid argument
    –> Cannot open /dev/sg4: Invalid argument

    Ambos resultam neste erro.

    2o. usb_modeswitch:

    Mesmo com as informações do log, estou na dúvida se este comando foi bem-sucedido, veja:
    $ usb_modeswitch -c /etc/usb_modeswitch.d/19d2\:2000
    Saída:
    Warning: TargetProductList overrides TargetProduct!

    Looking for target devices …
    Found devices in target mode or class (1)
    Looking for default devices …
    No devices in default mode or class found. Nothing to do. Bye.

    Bom, é isso… Se você puder me ajudar ^^

    Agradeço antecipadamente!

    Geraldo B. Landre

    • Geraldo acredito que o problema seja na identificação do código do produto. O código do meu modem MSA110up é 0091, mas o seu modem é de outro modelo, então você tem que descobrir qual o código do seu modem para alterar no arquivo /etc/usb_modeswitch.d/19d2\:2000. Infelizmente neste momento não tenho como testar mas acho que você consegue descobrir utilizando o comando lspci.
      Após identificar o modelo acrescente no arquivo e repita os procedimentos.
      Fique à vontade para retornar.
      Até breve 😉

      • Geraldo Barbosa Landre disse:

        Oi Brena! Como vai? Andei muito ocupado com outras coisas e agora que tive um tempo pra tentar resolver este problema de novo…

        Veja abaixo a saída do comando lspci, não consegui identificar o número…

        geraldo@queen:~$ lspci
        00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
        00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
        00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
        00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
        00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
        00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
        00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
        00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
        00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
        00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
        00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
        00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
        00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
        00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
        00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
        05:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01)
        06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
        ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
        ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
        ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
        ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
        ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
        ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

        Obrigado!

        Geraldo

  8. Valderi disse:

    Oi Brena, consegui finalmente conexão no modem, valeu tua paciência no passo a passo, obrigado.
    É preciso algumas “manhas” pra conectar mas acho que pode ter alguma coisa na configuração que deixei passar. Pra conectar fica assim:

    1 – Abrir terminal
    2 – plugar o modem
    3 – esperar até que a luz vermelha ligue pela segunda vez e chamar o comando wvdialconf até que ele reconheça o modem.
    4 – Após reconhecer chamar o o comando wvdial tim

    pronto, ele conecta na boa.

    Pouco a pouco vamos conhecendo melhor o linux, ainda tenho alguns desafios pra poder implantar na empresa:

    1 – Migrar o BD do ms-access para linux(tabelas, consultas, formulários, macros relatórios), já tentei o KEXI e o BASE mas não consigo criar formulários como no access, as ferramentas são poucas e o meu conhecimento muito limitado.
    Pergunta: Você conhece alguma maneira(programa) que eu possa usar para fazer isso?

    2 – Conexão windows x linux. Como fazer? Estou pesquisando muito e felizmente a comunidade é grande sempre se acha alguma coisa aqui ou ali. o problema é que as vezes se perde o foco e aí preciso recomeçar, mas isso faz parte do aprendizado.

    Grande abraço e mais uma vez obrigado pela tua ajuda.

    Valderi

  9. Valderi disse:

    Oi Brena, assim que testar vou postar o resultado, estou disposto a mudar para linux de vez, pra isso tenho que aprender muito ainda, mas é assim mesmo, toda mudança demora um pouco, uma vez que temos que quebrar um cultura que está enraizada, já uso o ubuntu faz algum tempo mas ainda tô devagar. estou com a versão 11.04 que está ainda melhor.

    Grande abraço.

    Valderi

  10. Valderi disse:

    Oi Brena, voltei, bem coloquei acima o retorno que obtive, precisei fazer algumas modificações: eu estava como usuário, mudei para administrador, eu tinha feito uma configuração em “editar conecções”, exclui essa configuração. Acho que estamos perto, para dar permissão total nas pasta ppp basta acessar com o botão direiro do mouse e mudar?

    Sds,

    Valderi

    • Ei Valderi.
      Não sei se vai precisar alterar a permissão da pasta ppp, eu não precisei.
      Quanto ao erro obtido: –> The PPP daemon has died: A modem hung up the phone (exit code = 16)
      Eu também recebo esse erro ao tentar conectar logo após plugar o modem.
      Tente plugar o modem, esperar a luz ficar verde e esperar mais um pouco antes de tentar conectar. Porque após de plugado o sistema vai reconhecê-lo como pendrive e vai verificar suas configurações do usb-modeswitch para enxergá-lo como modem. E às vezes esse processo pode ser meio lento.
      Teste ai.
      Aguardo retorno.
      E parabéns por não desistir.
      Até breve 😉

  11. Valderi disse:

    –> Sending: ATZ
    ATZ
    OK
    –> Sending: ATZ
    ATZ
    OK
    –> Sending: AT+CGDCONT=1,”ip”,”tim.br”
    AT+CGDCONT=1,”ip”,”tim.br”
    OK
    –> Modem initialized.
    –> Sending: ATDT*99***1#
    –> Waiting for carrier.
    ATDT*99***1#
    CONNECT 7200000
    –> Carrier detected. Starting PPP immediately.
    –> Starting pppd at Thu May 5 21:35:47 2011
    –> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
    –> –> PAP (Password Authentication Protocol) may be flaky.
    –> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
    –> –> CHAP (Challenge Handshake) may be flaky.
    –> Pid of pppd: 2443
    –> Using interface ppp0
    –> Disconnecting at Thu May 5 21:35:57 2011
    –> The PPP daemon has died: A modem hung up the phone (exit code = 16)
    –> man pppd explains pppd error codes in more detail.
    –> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
    –> Auto Reconnect will be attempted in 80 seconds

  12. andrew disse:

    por issso não perco tempo com linux e as empresas tbém porque o tempo é dinheiro infelismente perde muito tempo com terminais em veses do simples duplo click no windows,,vamos ver no linux 11.0 que vai mudar tudo agora,muito bom ja tava na hora

  13. Bom dia Brenda , uso um modem onda modelo msa190up da tim, fiz o procedimento como descrito no blog, ( usando ubuntu 10.10 no netbook acer aspire one ) quando conecto o modem ele começa a localizar , fica verde a luz do modem mas logo em sequida vem a msg , rede tim desconectada. nao faz a conexo para navegar , alguma diga sobre esse erro. Grato.

      • Boa noite, apos o comando sudo wvdial , da a seguinte menssagem:
        wvdial: internet dialer version 1.60
        Warmimg : section [dialer defaults] does not exist in wvdial.config
        cannot open /dev/modem:no such file or directory
        cannot open /dev/modem:no such file or directory
        cannot open /dev/modem:no such file or directory
        cannot open /dev/modem:no such file or directory

        • Olá Rogério

          O wvdial não esta conseguindo abrir os dispositivo localizado em /dev/modem
          Verifique se no seu arquivo /etc/wvdial.conf a propriedade modem está setada pra /dev/ttyUSB3

          Modem = /dev/ttyUSB3

          Até breve 😉

  14. Valderi disse:

    Oi Brena, tenho pena de vc, mas já procurei em vários lugares e vc é a pessoa com explicações claras. Como faço para editar o pppd. Segue o resultado da discagem.

    Grande abraço,

    Valderi

    vande@vande-laptop:~$ sudo wvdial tim
    –> WvDial: Internet dialer version 1.60
    –> Cannot get information for serial port.
    –> Initializing modem.
    –> Sending: ATZ
    ATZ
    OK
    –> Sending: ATZ
    ATZ
    OK
    –> Sending: AT+CGDCONT=1,”ip”,”tim.br”
    AT+CGDCONT=1,”ip”,”tim.br”
    OK
    –> Modem initialized.
    –> Sending: ATDT*99***1#
    –> Waiting for carrier.
    ATDT*99***1#
    CONNECT 7200000
    –> Carrier detected. Starting PPP immediately.
    –> Starting pppd at Tue Apr 26 21:02:02 2011
    –> Pid of pppd: 1926
    –> Disconnecting at Tue Apr 26 21:02:02 2011
    –> The PPP daemon has died: pppd options error (exit code = 2)
    –> man pppd explains pppd error codes in more detail.
    –> I guess that’s it for now, exiting
    –> The PPP daemon has died. (exit code = 2)
    vande@vande-laptop:~$

    • Valderi

      Execute novamente o comando sudo wvdial tim e depois execute tail /var/log/messages e post o resultado aqui.
      Achei umas possíveis soluções, mas não tenho como testar pois não obtenho esse erro.

      1ª Possível Solução

      Dá permissão total para os arquivos contidos na pasta /etc/ppp
      pap-secrets
      chap-secrets
      options

      2ª Possível solução

      sudo udevcontrol reload_rules

      sudo /etc/init.d/udev stop
      sudo /etc/init.d/udev start

      — espera um pouco, uns 15 seg
      sudo udevcontrol reload_rules

      sudo wvdial

      3ª Possível solução

      Desinstalar todos os pacotes instalados na tentativa de solucionar o problema (ppp/wvdial/…) e seguir do zero os passos do meu post.

      Qualquer dúvida, não hesite em perguntar.
      Até breve 😉

  15. Valderi disse:

    Olá Brena, segue a discagem do modem, ainda não sei o que pode estar errado.

    Sds.

    vande@vande-laptop:~$ wvdialconf
    Editing `/etc/wvdial.conf’.

    Scanning your serial ports for a modem.

    Modem Port Scan: S0 S1 S2 S3
    ttyUSB0: Device or resource busy
    Modem Port Scan: USB0
    WvModem: Cannot get information for serial port.
    ttyUSB1: ATQ0 V1 E1 — OK
    ttyUSB1: ATQ0 V1 E1 Z — OK
    ttyUSB1: ATQ0 V1 E1 S0=0 — OK
    ttyUSB1: ATQ0 V1 E1 S0=0 &C1 — OK
    ttyUSB1: ATQ0 V1 E1 S0=0 &C1 &D2 — OK
    ttyUSB1: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
    ttyUSB1: Modem Identifier: ATI — Manufacturer: ONDA COMMUNICATION
    ttyUSB1: Speed 9600: AT — OK
    ttyUSB1: Max speed is 9600; that should be safe.
    ttyUSB1: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
    ttyUSB2: Device or resource busy
    WvModem: Cannot get information for serial port.
    ttyUSB3: ATQ0 V1 E1 — OK
    ttyUSB3: ATQ0 V1 E1 Z — OK
    ttyUSB3: ATQ0 V1 E1 S0=0 — OK
    ttyUSB3: ATQ0 V1 E1 S0=0 &C1 — OK
    ttyUSB3: ATQ0 V1 E1 S0=0 &C1 &D2 — OK
    ttyUSB3: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
    ttyUSB3: Modem Identifier: ATI — Manufacturer: ONDA COMMUNICATION
    ttyUSB3: Speed 9600: AT — OK
    ttyUSB3: Max speed is 9600; that should be safe.
    ttyUSB3: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK

    Found a modem on /dev/ttyUSB1.
    Modem configuration written to /etc/wvdial.conf.
    /etc/wvdial.conf: Can’t write ‘/etc/wvdial.conf.tmp1825’: Permission denied
    /etc/wvdial.conf: Can’t write ‘/etc/wvdial.conf’ (‘/etc/wvdial.conf’): Bad file descriptor
    ttyUSB1: Speed 9600; init “ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0”
    ttyUSB3: Speed 9600; init “ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0″
    vande@vande-laptop:~$ wvdial tim
    –> WvDial: Internet dialer version 1.60
    –> Cannot get information for serial port.
    –> Initializing modem.
    –> Sending: ATZ
    ATZ
    OK
    –> Sending: ATZ
    ATZ
    OK
    –> Sending: AT+CGDCONT=1,”ip”,”tim.br”
    AT+CGDCONT=1,”ip”,”tim.br”
    OK
    –> Modem initialized.
    –> Sending: ATDT*99***1#
    –> Waiting for carrier.
    ATDT*99***1#
    CONNECT 7200000
    –> Carrier detected. Starting PPP immediately.
    –> Unable to run /usr/sbin/pppd.
    –> Check permissions, or specify a “PPPD Path” option in wvdial.conf.
    –> Timed out while dialing. Trying again.
    –> Sending: ATDT*99***1#
    –> Waiting for carrier.
    –> Timed out while dialing. Trying again.

    • Olá Valderi.
      Vamos por parte:
      1º Você está utilizando o comando “wvdialconf” que seta uma configuração padrão para o wvdial utilizar ao tentar se conectar. Basta editar o arquivo /etc/wvdial.conf e adicionar as configurações referentes à Tim, como mostro no passo três.

      2º Você está recebendo um erro de falta de permissão ao tentar executar o comando wvdial: “Unable to run /usr/sbin/pppd.
      –> Check permissions, or specify a “PPPD Path” option in wvdial.conf.”
      Tente executá-lo como root ou com “sudo wvdial tim”. Se mesmo assim não consegui conectar verifique a permissão de execução do pppd.

      Espero que funcione! Depois post o resultado obtido.

      Até breve

  16. Valderi disse:

    Oi Brena, o meu modem e da TIM, esta na porta usb1, ele tenta conectar mas nao consegue, passa um tempo e retorna mensagem `vc nao esta conectado`. Se tiver alguma ideia do que esta acontecendo, por favor me evise.

    Nota: quando tirei a configuracao VPN e reiniciei, o modem foi detectado e mostrou uma tela de configuracao segui os passos mas ficou na situacao acima.

    sds,

    Ate breve.

    • Ei Valderi.
      Essa mensagem de não está conectado aparece em que lugar? Porque também recebo uma mensagem semelhante do Network Connections, apesar de está conectado.
      Você instalou o wvdial?
      Para poder lhe auxiliar melhor seria preciso ver o log do que acontece quando você tenta acessar.
      Post todo o conteúdo que aparece no terminal depois que você executa o comando: wvdial tim
      Até breve 😉

  17. Valderi disse:

    Oi Brena, fiz a configuração acima mas devo estar esquecendo algum detalhe. O modem é reconhecido mas não faz a conexão. No wvdialconf na linha phone é pra colocar somente o número com DDD? E a configuração VPN tb colocar da mesma forma? Em ambos deixar algum caracter especial?

    Grande abraço e parabéns pelo blog.

    Sds.

    • Olá Valderi.
      Seu modem é da Tim? Se for pode usar este número na linha phone *99***1#, também já vi algumas pessoas usando *99#.
      Até onde sei não é necessário realizar nenhuma configuração de VPN para poder utilizar o 3g.
      Obrigada.
      Até breve 😉

  18. Christian J. Bosque disse:

    Ola Brena, muito bom seu post, vc sabe me dizer se esse processo funciona para o Nokia C3 modo Modem? msm assim vou tentar e ta de parabenn.

    Ate

  19. jose disse:

    Brenda, dá pra facilitar mais ainda…

    no primeiro passo é só executar no terminal:
    sudo apt-get install usb-modeswitch usb-modeswitch-data wvdial

    ou pesquisar “usb-m” e “wvd” no Ubuntu Software Center

    No Linux mint voce só precisa instalar o wvdial

    • Olá Jose
      Existem várias formas de configurar. A que fiz com certeza não é a mais fácil, mas foi a que encontrei na época.
      De qualquer forma sua dica é válida para poder facilitar quem ainda está com dificuldades pra instalar.
      Outro fato também é que nem sempre é possível conectar o PC na internet para baixar os pacotes via apt-get, então a pessoa precisa saber quais bibliotecas baixar para colocar em um pendrive e depois fazer a instalação.
      Até breve 😉

  20. Marcos Nascimento disse:

    Passados todos esses anos de Linux (em todas as suas distribuições) e o sistema continua sendo apenas para entusiastas em informática. Para nós, simples usuários que não temos tempo nem saco para essas viagens pelo virtual, fica o bom e velho Windows, onde tudo é rápido e fácil. Instalei o Ubuntu 10.10 por ter lido que é melhor que o Windows. Até gostei, mas não troco pelo meu velho e original Windows XP Prefessional.

    • Estanis disse:

      Ocorre que este modem era um modelo novo utilizado pela TIM e infelizmente muitos fornecedores de hardware acham que só existem um sistema operacional (Windows). Pessoas como o Josh, que trabalham na compatibilidade de drivers que o fabricante não dão suporte, estão de parabéns. Como o Josh não tem acesso a todos os modelos de modems, a comunidade precisa fazer a sua parte, como foi o meu caso, debuguei esse dispositivo e deixei a disposição para o Josh. Sim, eu passei 2 dias em cima desse modem para debugá-lo e achar a solução juntamente com a ajuda do Josh. Outros modems que já estão há um bom tempo no mercado, como é o caso do huawei, é muito mais suportável no Linux que no Windows, não necessitando de qualquer software adicional. Parabéns ao autor do site em criar um tutorial para ajudar o pessoal.

      • Olá Estanis.
        Em primeiro lugar parabéns pelo seu trabalho em facilitar a vida dos usuários Linux.
        Eu fiquei mais de um mês tentando configurar, e hoje este post é o mais visitado do meu blog.
        Obrigada pelo comentário e pela parabenização.
        Até breve 😉

  21. Emilio disse:

    Como você fez para descobrir em qual ttyUSB o modem foi conectado?
    Andei pesquisando e ele pode “criar” 4 tty

    ttyUSB0
    ttyUSB1
    ttyUSB2
    ttyUSB3

    Como saber ao certo qual foi o ttyUSB que o modem vai discar?

  22. Junior disse:

    Brena,

    na hora de reconhecer como modem ele nao encontra:

    # usb_modeswitch -c /etc/usb_modeswitch.d/19d2\:2000
    Warning: TargetProductList overrides TargetProduct!

    Looking for target devices …
    Found devices in target mode or class (1)
    Looking for default devices …
    No devices in default mode or class found. Nothing to do. Bye.

    # cat /etc/usb_modeswitch.d/19d2\:2000
    ########################################################
    # ZTE devices

    DefaultVendor= 0x19d2
    DefaultProduct= 0x2000

    TargetVendor= 0x19d2
    TargetProductList=”0001,0002,0015,0016,0017,0031,0037,0052,0055,0063,0064,0108,0128,0091″

    MessageContent=”5553424312345678000000000000061e000000000000000000000000000000″
    MessageContent2=”5553424312345679000000000000061b000000020000000000000000000000″
    MessageContent3=”55534243123456702000000080000c85010101180101010101000000000000″

    NeedResponse=1

    CheckSuccess=20

    # lsusb
    Bus 002 Device 003: ID 413c:3012 Dell Computer Corp. Optical Wheel Mouse
    Bus 002 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 015: ID 19d2:0091 ONDA Communication S.p.A.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    • Segue o meu arquivo /etc/usb_modeswitch.d/19d2\:2000

      — Início —

      ########################################################
      # ZTE devices

      DefaultVendor= 0x19d2
      DefaultProduct= 0x2000

      TargetVendor= 0x19d2
      TargetProductList=”0001,0002,0015,0016,0017,0031,0037,0052,0055,0063,0064,0108,0128,0091″

      MessageContent=”5553424312345678000000000000061e000000000000000000000000000000″
      MessageContent2=”5553424312345679000000000000061b000000020000000000000000000000″
      MessageContent3=”55534243123456702000000080000c85010101180101010101000000000000″

      NeedResponse=1

      CheckSuccess=20

      — Fim —

      Qualquer coisa posta ai 😉

  23. Max disse:

    OOOi Brena, valeu pelo post, foi o único que deu pra entender o passo-a-passo ja q sou novo no linux huahua
    Mas assim, baixei os pacotes, instalei, modifiquei seguindo seus passos, mas na hora de reconhecer como modem e nao como storage olha só no que dá:

    max@max-laptop:~$ usb_modeswitch -c /etc/usb_modeswitch.d/19d2\:2000
    Warning: TargetProductList overrides TargetProduct!

    Looking for target devices …
    Found devices in target mode or class (1)
    Looking for default devices …
    No devices in default mode or class found. Nothing to do. Bye.

    Será que fiz alguma coisa errada ou ta faltando fazer algo? Pode me ajudar?
    Bjsss, vlw!

      • mikE mendeS disse:

        Brena Monteiro Bom Dia!
        uso ubuntu 10.10, consigo entrar na net pelo meu Nokia N96, quando coleguo em modo PC-suite no meu ubuntu 10.10 usando gnome-ppp consigo detectar o modem e tudo.. tento conectar e diz que conecta mas naum consigo nem pingar o google.com e nem abrir algum site!

        meus dados ke vi em algum tutorial por ae..
        eu coloco assim no gnome-ppp:
        Username: tim
        Password: tim
        Phone number: *99***1#

        esse telefone tah certo? pra se conectar pela TIM?

        qualker ajuda serei eternamente grato!

        mikE, Fortaleza – CE.

        • mikE mendeS

          Atualmente não tenho utilizado mais o 3G, entretanto até a última vez que utilizei o usuário, a senha e o número eram estes mesmo que você esta tentando utilizar.

  24. Brena
    por acaso voce nao tem já baixado todos esses downloads
    que possa enviar para mim ou, acessar remotamente meu notebook para fazer este trabalho, porque eu nao entendo muito de computaçao e gostaria de navegar no meu ubuntu com esse modem da tim. Entendo mesmo é de desenhos e projetos e, vai o meu pequeno site (www.wix.com/util1010/swytons), que estou criando, pra voce visitar e dar sua opiniao por email. Pode ser…

    Ricardo
    Fortaleza-CE

  25. .Sean disse:

    Legal sua explicação…
    Só achei meio estranho pois no meu Ubuntu ele conecta automáticamente o 3g desde o 8.10…
    =)

    • Obrigada Rudy. Deu canseira sim, quase desisti, mas depois de configurado compensa e muito poder voltar usar Linux \o/ E pelo que vi essa forma deve funcionar para qualquer distro.
      Até breve.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s